JAWS Screen Reader Adaptation for Mozilla Firefox

21st Mar 2005

you need JAWS and Firefox to run this (it's not a Firefox extension).

accessibility